Merge branch 'gtk3'
[projects/chimara/chimara.git] / interpreters / nitfol / Makefile.am
index 82791cb6ca895ffd7cbe0e8f73103f32f4c918fb..1e721b1f90bb48ec11887b364b287c46569151e9 100644 (file)
@@ -1,9 +1,9 @@
-GRAPHICS = no_graph.c no_graph.h
-GRAPHICS = graphics.c graphics.h
+#GRAPHICS = no_graph.c no_graph.h
+GRAPHICS = graphics.c graphics.h
 BLORB = blorb.c 
 # BLORB = no_blorb.c
-SOUND = no_snd.c no_snd.h
-SOUND = sound.c sound.h
+SOUND = no_snd.c no_snd.h
+SOUND = sound.c sound.h
 
 dist_noinst_SCRIPTS = copying.awk opt2glkc.pl y2help.pl
 
@@ -29,27 +29,31 @@ nitfol_TEXINFOS = dbg_help.texi options.texi
 # man_MANS = nitfol.6
 
 BUILT_SOURCES = copying.c dbg_help.h startunix.c dbg_help.texi options.texi
-CLEANFILES = $(BUILT_SOURCES) nitfol.6 
+CLEANFILES = $(BUILT_SOURCES) nitfol.6
+DISTCLEANFILES = inform.c nitfol.info
+MAINTAINERCLEANFILES = texinfo.tex
 
 dbg_help.h: inform.y y2help.pl
-       $(PERL) $(srcdir)/y2help.pl $(srcdir)/inform.y
+       $(AM_V_GEN)$(PERL) $(srcdir)/y2help.pl $(srcdir)/inform.y
 
 dbg_help.texi: inform.y y2help.pl
-       $(PERL) $(srcdir)/y2help.pl $(srcdir)/inform.y
+       $(AM_V_GEN)$(PERL) $(srcdir)/y2help.pl $(srcdir)/inform.y
 
 copying.c: COPYING copying.awk
-       $(AWK) -f $(srcdir)/copying.awk <$(srcdir)/COPYING >copying.c
+       $(AM_V_GEN)$(AWK) -f $(srcdir)/copying.awk <$(srcdir)/COPYING >copying.c
 
 # nitfol.6: nitfol.opt opt2glkc.pl
-#      $(PERL) $(srcdir)/opt2glkc.pl -man $(srcdir)/nitfol.opt
+#      $(AM_V_GEN)$(PERL) $(srcdir)/opt2glkc.pl -man $(srcdir)/nitfol.opt
 
 options.texi: nitfol.opt opt2glkc.pl
-       $(PERL) $(srcdir)/opt2glkc.pl -info $(srcdir)/nitfol.opt
+       $(AM_V_GEN)$(PERL) $(srcdir)/opt2glkc.pl -info $(srcdir)/nitfol.opt
 
 startunix.c: nitfol.opt opt2glkc.pl
-       $(PERL) $(srcdir)/opt2glkc.pl -unix $(srcdir)/nitfol.opt
+       $(AM_V_GEN)$(PERL) $(srcdir)/opt2glkc.pl -unix $(srcdir)/nitfol.opt
 
 EXTRA_DIST = nitfol.opt crashme.inf test.inf 
 
 nitfoldocdir = $(datadir)/doc/$(PACKAGE)/nitfol
 dist_nitfoldoc_DATA = ChangeLog COPYING INSTALL README
+
+-include $(top_srcdir)/git.mk