Moved to updated gettext and did some tweaking for make distcheck
[projects/chimara/chimara.git] / interpreters / nitfol / Makefile.am
index b5d3099acd500fa2d6733a9b8c576f2dff7e3ee7..10ec1329fab39ca19f5aef6d30619ff3c128c08d 100644 (file)
@@ -5,22 +5,24 @@ PLUGIN_LIBTOOL_FLAGS=-module -avoid-version -export-symbols-regex "^glk"
 GRAPHICS = no_graph.c no_graph.h
 # GRAPHICS = graphics.c graphics.h
 BLORB = blorb.c 
-# BLORB = no_blorb.c no_blorb.h
+# BLORB = no_blorb.c
 SOUND = no_snd.c no_snd.h
 # SOUND = sound.c sound.h
 
 pkglib_LTLIBRARIES = nitfol.la
-nitfol_la_SOURCES = automap.c automap.h binary.h debug.c debug.h decode.c \
-       decode.h errmesg.c errmesg.h globals.c globals.h hash.c hash.h iff.c iff.h \
-       infix.c infix.h inform.c inform.h init.c init.h io.c linkevil.h main.c \
-       main.h nio.h nitfol.h objects.c objects.h op_call.c op_call.h op_jmp.c \
-       op_jmp.h oplist.c oplist.h op_math.c op_math.h op_save.c op_save.h \
-       op_table.c op_table.h op_v6.c op_v6.h portfunc.c portfunc.h quetzal.c \
-       quetzal.h solve.c solve.h stack.c stack.h startunix.c struct.c struct.h \
-       tokenise.c tokenise.h undo.c undo.h z_io.c z_io.h zscii.c zscii.h \
+nitfol_la_SOURCES = automap.c automap.h binary.h copying.h debug.c debug.h \
+       decode.c decode.h errmesg.c errmesg.h globals.c globals.h hash.c hash.h \
+       iff.c iff.h infix.c infix.h inform.c inform.h init.c init.h io.c \
+       linkevil.h main.c main.h nio.h nitfol.h no_blorb.h objects.c objects.h \
+       op_call.c op_call.h op_jmp.c op_jmp.h oplist.c oplist.h op_math.c \
+       op_math.h op_save.c op_save.h op_table.c op_table.h op_v6.c op_v6.h \
+       portfunc.c portfunc.h quetzal.c quetzal.h solve.c solve.h stack.c stack.h \
+       startunix.c struct.c struct.h tokenise.c tokenise.h undo.c undo.h z_io.c \
+       z_io.h zscii.c zscii.h \
        $(GRAPHICS) \
        $(BLORB) \
        $(SOUND)
+nitfol_la_CPPFLAGS = -I$(top_srcdir)
 nitfol_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
 
 EXTRA_DIST = crashme.inf test.inf