Add Glulxe and Git. They compile but don't work yet.
[projects/chimara/chimara.git] / interpreters / glulxe / Makefile.am
diff --git a/interpreters/glulxe/Makefile.am b/interpreters/glulxe/Makefile.am
new file mode 100644 (file)
index 0000000..eb2b661
--- /dev/null
@@ -0,0 +1,13 @@
+PLUGIN_LIBTOOL_FLAGS=-module -avoid-version -export-symbols-regex "^glk"
+
+pkglib_LTLIBRARIES = glulxe.la
+glulxe_la_SOURCES = accel.c exec.c files.c funcs.c gestalt.c gestalt.h glkop.c \
+    glulxe.h heap.c main.c opcodes.h operand.c osdepend.c profile.c search.c \
+    serial.c string.c unixstrt.c vm.c 
+glulxe_la_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/libchimara
+glulxe_la_CFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -Wno-unused \
+    -DOS_UNIX $(AM_CFLAGS)
+glulxe_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+
+glulxedocdir = $(datadir)/doc/$(PACKAGE)/glulxe
+dist_glulxedoc_DATA = README