Merge branch 'gtk3'
[projects/chimara/chimara.git] / interpreters / git / Makefile.am
index 2257391e77a7d15701b3cbf142b46669a64409a9..f025600644845224b72869f21d35875083566ae7 100644 (file)
@@ -1,14 +1,12 @@
-PLUGIN_LIBTOOL_FLAGS=-module -avoid-version -export-symbols-regex "^glk"
-
 # Automatically generate version.h
 MAJOR = 1
 MINOR = 2
-PATCH = 4
-version.h: Makefile
-       echo "// Automatically generated file -- do not edit!" > version.h
-       echo "#define GIT_MAJOR" $(MAJOR) >> version.h
-       echo "#define GIT_MINOR" $(MINOR) >> version.h
-       echo "#define GIT_PATCH" $(PATCH) >> version.h
+PATCH = 9
+version.h: Makefile.am
+       $(AM_V_GEN)echo "// Automatically generated file -- do not edit!" > version.h
+       $(AM_V_at)echo "#define GIT_MAJOR" $(MAJOR) >> version.h
+       $(AM_V_at)echo "#define GIT_MINOR" $(MINOR) >> version.h
+       $(AM_V_at)echo "#define GIT_PATCH" $(PATCH) >> version.h
 
 pkglib_LTLIBRARIES = git.la
 BUILT_SOURCES = version.h
@@ -17,20 +15,22 @@ git_la_SOURCES = version.h git.h config.h compiler.h memory.h opcodes.h \
     opcodes.c operands.c peephole.c savefile.c saveundo.c search.c terp.c \
     accel.c
 git_la_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/libchimara
-git_la_CFLAGS = -DUSE_MMAP -DUSE_INLINE $(AM_CFLAGS)
-git_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+git_la_CFLAGS = -DCHIMARA_EXTENSIONS -DUSE_INLINE $(AM_CFLAGS)
+git_la_LDFLAGS = -module $(PLUGIN_LIBTOOL_FLAGS)
 
 gitdocdir = $(datadir)/doc/$(PACKAGE)/git
 dist_gitdoc_DATA = README.txt
 
-CLEANFILES = test/*.tmp
+CLEANFILES = version.h test/*.tmp
 
 #TESTS = test/test.sh \
 #      test/Alabaster.gblorb test/Alabaster.walk test/Alabaster.golden
 #
 #test: git
 #      sh test/test.sh
-       
+
+# Memory mapping (-DUSE_MMAP) doesn't seem to work... FIXME
+
 # Best settings for GCC 2.95. This generates faster code than
 # GCC 3, so you should use this setup if possible.
 #CC = gcc -Wall -O3
@@ -43,4 +43,6 @@ CLEANFILES = test/*.tmp
 #
 # Mac OS X (PowerPC) settings.
 #CC = gcc2 -Wall -O3 -no-cpp-precomp
-#OPTIONS = -DUSE_DIRECT_THREADING -DUSE_BIG_ENDIAN_UNALIGNED -DUSE_MMAP -DUSE_INLINE
\ No newline at end of file
+#OPTIONS = -DUSE_DIRECT_THREADING -DUSE_BIG_ENDIAN_UNALIGNED -DUSE_MMAP -DUSE_INLINE
+
+-include $(top_srcdir)/git.mk