Applied patches to Git interpreter from Gargoyle source code
[projects/chimara/chimara.git] / interpreters / git / Makefile.am
index b9881a60a91e10da9fdf4ad09ebc45714fc08079..051eeb35c2fd79cb3bdfcbf3130e5710dc8f01ef 100644 (file)
@@ -17,7 +17,7 @@ git_la_SOURCES = version.h git.h config.h compiler.h memory.h opcodes.h \
     opcodes.c operands.c peephole.c savefile.c saveundo.c search.c terp.c \
     accel.c
 git_la_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/libchimara
-git_la_CFLAGS = -DUSE_INLINE $(AM_CFLAGS)
+git_la_CFLAGS = -DCHIMARA_EXTENSIONS -DUSE_INLINE $(AM_CFLAGS)
 git_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
 
 gitdocdir = $(datadir)/doc/$(PACKAGE)/git
@@ -45,4 +45,4 @@ CLEANFILES = test/*.tmp
 #
 # Mac OS X (PowerPC) settings.
 #CC = gcc2 -Wall -O3 -no-cpp-precomp
-#OPTIONS = -DUSE_DIRECT_THREADING -DUSE_BIG_ENDIAN_UNALIGNED -DUSE_MMAP -DUSE_INLINE
\ No newline at end of file
+#OPTIONS = -DUSE_DIRECT_THREADING -DUSE_BIG_ENDIAN_UNALIGNED -DUSE_MMAP -DUSE_INLINE