Added chimara_if_run() which, given a game file, autodetects the type by its extensio...
[projects/chimara/chimara.git] / interpreters / frotz / Makefile.am
index 02d88efc188bee624f3428f5cb71704cdd4565b4..f1a010026927ac8979744e044b5c024bee8b11a7 100644 (file)
@@ -1,12 +1,10 @@
-PLUGIN_LIBTOOL_FLAGS=-module -avoid-version -export-symbols-regex "^glk"
-
 pkglib_LTLIBRARIES = frotz.la
 frotz_la_SOURCES = buffer.c err.c fastmem.c files.c input.c main.c math.c \
        object.c process.c quetzal.c random.c redirect.c sound.c stream.c table.c \
        text.c variable.c glkscreen.c glkmisc.c frotz.h glkfrotz.h glkio.h setup.h
 frotz_la_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/libchimara
 frotz_la_CFLAGS = -Wno-pointer-sign $(AM_CFLAGS)
-frotz_la_LDFLAGS = $(PLUGIN_LIBTOOL_FLAGS)
+frotz_la_LDFLAGS = -module $(PLUGIN_LIBTOOL_FLAGS)
 
 frotzdocdir = $(datadir)/doc/$(PACKAGE)/frotz
 dist_frotzdoc_DATA = AUTHORS COPYING README TODO