Iliad port
[rodin/chimara.git] / interpreters / frotz / Makefile.am
index f1a010026927ac8979744e044b5c024bee8b11a7..f72505c53c4e01ccc9d436f942dd8a659f1f9cc9 100644 (file)
@@ -3,7 +3,15 @@ frotz_la_SOURCES = buffer.c err.c fastmem.c files.c input.c main.c math.c \
        object.c process.c quetzal.c random.c redirect.c sound.c stream.c table.c \
        text.c variable.c glkscreen.c glkmisc.c frotz.h glkfrotz.h glkio.h setup.h
 frotz_la_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/libchimara
-frotz_la_CFLAGS = -Wno-pointer-sign $(AM_CFLAGS)
+
+if TARGET_ILIAD
+no_pointer_sign = 
+else
+no_pointer_sign = -Wno-pointer-sign
+endif
+
+frotz_la_CFLAGS = $(no_pointer_sign) $(AM_CFLAGS)
+
 frotz_la_LDFLAGS = -module $(PLUGIN_LIBTOOL_FLAGS)
 
 frotzdocdir = $(datadir)/doc/$(PACKAGE)/frotz