Fixed documentation to work with Gtk-Doc 1.14 and produce as few warnings as possible
[rodin/chimara.git] / docs / reference / Makefile.am
index c039fb8abe30699da72028164e47292e646c9a02..ac9181d8b6a0352bbbf85263a36efa4d001b56f4 100644 (file)
@@ -34,7 +34,11 @@ MKTMPL_OPTIONS =
 
 # Extra options to supply to gtkdoc-mkhtml
 # The --path is because Gtk-doc is broken on non-distcheck vpath builds! Sigh.
-MKHTML_OPTIONS = --path="$(abs_builddir)"
+# But it only works on Gtk-doc 1.11 and higher. So if you want to do a vpath
+# build then uncomment this and require 1.11 in configure.ac. If you want to do
+# vpath build on Debian, then you're S.O.L. Complain to Gtk-doc and Debian.
+# MKHTML_OPTIONS = --path="$(abs_builddir)"
+MKHTML_OPTIONS = 
 
 # Extra options to supply to gtkdoc-fixref. Not normally needed.
 FIXXREF_OPTIONS = 
@@ -47,8 +51,9 @@ CFILE_GLOB = $(top_srcdir)/libchimara/*.c
 EXTRA_HFILES = 
 
 # Header files to ignore when scanning. Use base file name, no paths
-IGNORE_HFILES = chimara-glk-private.h \
-       abort.h charset.h event.h input.h stream.h window.h
+IGNORE_HFILES = chimara-glk-private.h chimara-marshallers.h \
+       abort.h charset.h event.h fileref.h graphics.h hyperlink.h init.h input.h \
+       magic.h mouse.h pager.h resource.h stream.h strio.h style.h timer.h window.h
 
 # Images to copy into HTML directory.
 HTML_IMAGES = \