Documented all planned Glk API functions
[rodin/chimara.git] / docs / reference / Makefile.am
index f7f5ee528b81881a54d8687b461a2e4a73344722..1c393a685eea48ecd091fd1309cb0c33e150149c 100644 (file)
@@ -33,6 +33,11 @@ MKDB_OPTIONS = --sgml-mode --output-format=xml
 MKTMPL_OPTIONS = 
 
 # Extra options to supply to gtkdoc-mkhtml
+# The --path is because Gtk-doc is broken on non-distcheck vpath builds! Sigh.
+# But it only works on Gtk-doc 1.11 and higher. So if you want to do a vpath
+# build then uncomment this and require 1.11 in configure.ac. If you want to do
+# vpath build on Debian, then you're S.O.L. Complain to Gtk-doc and Debian.
+# MKHTML_OPTIONS = --path="$(abs_builddir)"
 MKHTML_OPTIONS = 
 
 # Extra options to supply to gtkdoc-fixref. Not normally needed.
@@ -46,31 +51,32 @@ CFILE_GLOB = $(top_srcdir)/libchimara/*.c
 EXTRA_HFILES = 
 
 # Header files to ignore when scanning. Use base file name, no paths
-IGNORE_HFILES = chimara-glk-private.h \
-       abort.h charset.h event.h input.h stream.h window.h
+IGNORE_HFILES = chimara-glk-private.h chimara-marshallers.h \
+       abort.h charset.h event.h fileref.h graphics.h hyperlink.h init.h input.h \
+       magic.h mouse.h pager.h resource.h stream.h strio.h style.h timer.h window.h
 
 # Images to copy into HTML directory.
 HTML_IMAGES = \
-       $(srcdir)/images/fig1.png \
-       $(srcdir)/images/fig2.png \
-       $(srcdir)/images/fig3a.png \
-       $(srcdir)/images/fig3b.png \
-       $(srcdir)/images/fig3c.png \
-       $(srcdir)/images/fig4a.png \
-       $(srcdir)/images/fig4b.png \
-       $(srcdir)/images/fig4c.png \
-       $(srcdir)/images/fig5-7a.png \
-       $(srcdir)/images/fig6.png \
-       $(srcdir)/images/fig7b.png \
-       $(srcdir)/images/fig7c.png \
-       $(srcdir)/images/fig7d.png \
-       $(srcdir)/images/fig7e.png \
-       $(srcdir)/images/fig8a.png \
-       $(srcdir)/images/fig8b.png \
-       $(srcdir)/images/fig8c.png \
-       $(srcdir)/images/fig9.png \
-       $(srcdir)/images/fig10.png \
-       $(srcdir)/images/fig11.png
+       images/fig1.png \
+       images/fig2.png \
+       images/fig3a.png \
+       images/fig3b.png \
+       images/fig3c.png \
+       images/fig4a.png \
+       images/fig4b.png \
+       images/fig4c.png \
+       images/fig5-7a.png \
+       images/fig6.png \
+       images/fig7b.png \
+       images/fig7c.png \
+       images/fig7d.png \
+       images/fig7e.png \
+       images/fig8a.png \
+       images/fig8b.png \
+       images/fig8c.png \
+       images/fig9.png \
+       images/fig10.png \
+       images/fig11.png
 
 # Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
 content_files = version.xml \
@@ -86,6 +92,7 @@ content_files = version.xml \
        glk-window-arrangement.sgml \
        glk-display-style.sgml \
        glk-other-events.sgml \
+       glk-sound-resources.sgml \
        glk-porting.sgml \
        dispatch.sgml \
        blorb.sgml \