Documented all planned Glk API functions
[rodin/chimara.git] / docs / reference / Makefile.am
index c039fb8abe30699da72028164e47292e646c9a02..1c393a685eea48ecd091fd1309cb0c33e150149c 100644 (file)
@@ -34,7 +34,11 @@ MKTMPL_OPTIONS =
 
 # Extra options to supply to gtkdoc-mkhtml
 # The --path is because Gtk-doc is broken on non-distcheck vpath builds! Sigh.
-MKHTML_OPTIONS = --path="$(abs_builddir)"
+# But it only works on Gtk-doc 1.11 and higher. So if you want to do a vpath
+# build then uncomment this and require 1.11 in configure.ac. If you want to do
+# vpath build on Debian, then you're S.O.L. Complain to Gtk-doc and Debian.
+# MKHTML_OPTIONS = --path="$(abs_builddir)"
+MKHTML_OPTIONS = 
 
 # Extra options to supply to gtkdoc-fixref. Not normally needed.
 FIXXREF_OPTIONS = 
@@ -47,8 +51,9 @@ CFILE_GLOB = $(top_srcdir)/libchimara/*.c
 EXTRA_HFILES = 
 
 # Header files to ignore when scanning. Use base file name, no paths
-IGNORE_HFILES = chimara-glk-private.h \
-       abort.h charset.h event.h input.h stream.h window.h
+IGNORE_HFILES = chimara-glk-private.h chimara-marshallers.h \
+       abort.h charset.h event.h fileref.h graphics.h hyperlink.h init.h input.h \
+       magic.h mouse.h pager.h resource.h stream.h strio.h style.h timer.h window.h
 
 # Images to copy into HTML directory.
 HTML_IMAGES = \
@@ -87,6 +92,7 @@ content_files = version.xml \
        glk-window-arrangement.sgml \
        glk-display-style.sgml \
        glk-other-events.sgml \
+       glk-sound-resources.sgml \
        glk-porting.sgml \
        dispatch.sgml \
        blorb.sgml \