Documented all planned Glk API functions
[rodin/chimara.git] / docs / reference / Makefile.am
index 77789f74f24a6581d5f66f50a06651a88f0de786..1c393a685eea48ecd091fd1309cb0c33e150149c 100644 (file)
@@ -33,6 +33,11 @@ MKDB_OPTIONS = --sgml-mode --output-format=xml
 MKTMPL_OPTIONS = 
 
 # Extra options to supply to gtkdoc-mkhtml
+# The --path is because Gtk-doc is broken on non-distcheck vpath builds! Sigh.
+# But it only works on Gtk-doc 1.11 and higher. So if you want to do a vpath
+# build then uncomment this and require 1.11 in configure.ac. If you want to do
+# vpath build on Debian, then you're S.O.L. Complain to Gtk-doc and Debian.
+# MKHTML_OPTIONS = --path="$(abs_builddir)"
 MKHTML_OPTIONS = 
 
 # Extra options to supply to gtkdoc-fixref. Not normally needed.
@@ -46,34 +51,36 @@ CFILE_GLOB = $(top_srcdir)/libchimara/*.c
 EXTRA_HFILES = 
 
 # Header files to ignore when scanning. Use base file name, no paths
-IGNORE_HFILES = chimara-glk-private.h \
-       abort.h charset.h event.h input.h stream.h window.h
+IGNORE_HFILES = chimara-glk-private.h chimara-marshallers.h \
+       abort.h charset.h event.h fileref.h graphics.h hyperlink.h init.h input.h \
+       magic.h mouse.h pager.h resource.h stream.h strio.h style.h timer.h window.h
 
 # Images to copy into HTML directory.
 HTML_IMAGES = \
-       $(srcdir)/images/fig1.png \
-       $(srcdir)/images/fig2.png \
-       $(srcdir)/images/fig3a.png \
-       $(srcdir)/images/fig3b.png \
-       $(srcdir)/images/fig3c.png \
-       $(srcdir)/images/fig4a.png \
-       $(srcdir)/images/fig4b.png \
-       $(srcdir)/images/fig4c.png \
-       $(srcdir)/images/fig5-7a.png \
-       $(srcdir)/images/fig6.png \
-       $(srcdir)/images/fig7b.png \
-       $(srcdir)/images/fig7c.png \
-       $(srcdir)/images/fig7d.png \
-       $(srcdir)/images/fig7e.png \
-       $(srcdir)/images/fig8a.png \
-       $(srcdir)/images/fig8b.png \
-       $(srcdir)/images/fig8c.png \
-       $(srcdir)/images/fig9.png \
-       $(srcdir)/images/fig10.png \
-       $(srcdir)/images/fig11.png
+       images/fig1.png \
+       images/fig2.png \
+       images/fig3a.png \
+       images/fig3b.png \
+       images/fig3c.png \
+       images/fig4a.png \
+       images/fig4b.png \
+       images/fig4c.png \
+       images/fig5-7a.png \
+       images/fig6.png \
+       images/fig7b.png \
+       images/fig7c.png \
+       images/fig7d.png \
+       images/fig7e.png \
+       images/fig8a.png \
+       images/fig8b.png \
+       images/fig8c.png \
+       images/fig9.png \
+       images/fig10.png \
+       images/fig11.png
 
 # Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
 content_files = version.xml \
+       selectors.xml \
        glk-front-matter.sgml \
        glk-introduction.sgml \
        glk-main-function.sgml \
@@ -84,7 +91,12 @@ content_files = version.xml \
        glk-windows.sgml \
        glk-window-arrangement.sgml \
        glk-display-style.sgml \
-       glk-other-events.sgml
+       glk-other-events.sgml \
+       glk-sound-resources.sgml \
+       glk-porting.sgml \
+       dispatch.sgml \
+       blorb.sgml \
+       blorb-library.sgml
 
 # SGML files where gtk-doc abbreviations (#GtkWidget) are expanded
 # These files must be listed here *and* in content_files
@@ -112,10 +124,18 @@ EXTRA_DIST += version.xml.in
 # Files not to distribute
 # for --rebuild-types in $(SCAN_OPTIONS), e.g. $(DOC_MODULE).types
 # for --rebuild-sections in $(SCAN_OPTIONS), e.g. $(DOC_MODULE)-sections.txt
-DISTCLEANFILES = $(DOC_MODULE)-overrides.txt
+CLEANFILES += selectors.xml
+DISTCLEANFILES = version.xml $(DOC_MODULE)-overrides.txt
+
+# Uncomment this if you want your docs-status tested during 'make check'
+# Comment this while not all symbols are documented, otherwise distcheck fails
+#if ENABLE_GTK_DOC
+#TESTS_ENVIRONMENT = cd $(srcdir) &&
+#TESTS = $(GTKDOC_CHECK)
+#endif
+
+dist_noinst_SCRIPTS = build-selector-table.pl
+
+selectors.xml: $(srcdir)/../../libchimara/gi_dispa.c
+       $(PERL) build-selector-table.pl $< > $@
 
-# Comment this out if you want your docs-status tested during 'make check'
-if ENABLE_GTK_DOC
-TESTS_ENVIRONMENT = cd $(srcdir) &&
-TESTS = $(GTKDOC_CHECK)
-endif