clarify how the nodata option should be specified in the config file for mysql
[matthijs/upstream/backupninja.git] / src / Makefile.am
index 44b314845c885980fd215c1c2fa43d124edd8ec3..3d5bdb8d630e443cd99b7d23cd80939a6f3951b3 100644 (file)
@@ -4,15 +4,17 @@ sbin_SCRIPTS  = backupninja ninjahelper
 # a proto je taky musíme smazat ...
 CLEANFILES = $(sbin_SCRIPTS)
 
-EXTRA_DIST = backupninja.in ninjahelper.in
+EXTRA_DIST = backupninja.in ninjahelper.in ninjareport.in
 
 edit = sed \
     -e "s,@CFGDIR\@,$(CFGDIR),g" \
     -e "s,@BASH\@,$(BASH),g" \
+    -e "s,@AWK\@,$(AWK),g" \
+    -e "s,@SED\@,$(SED),g" \
     -e 's,@datadir\@,$(pkgdatadir),g' \
     -e "s,@libdir\@,$(pkglibdir),g" \
     -e 's,@localstatedir\@,$(localstatedir),g' \
-       -e 's,@prefix\@,$(prefix),g'
+    -e 's,@prefix\@,$(prefix),g'
 
 #install-exec-hook:
 
@@ -26,3 +28,7 @@ ninjahelper: $(srcdir)/ninjahelper.in
        $(edit) $(srcdir)/ninjahelper.in > ninjahelper
        chmod ugo+x ninjahelper
 
+ninjareport: $(srcdir)/ninjareport.in
+       rm -f ninjareport
+       $(edit) $(srcdir)/ninjareport.in > ninjareport
+       chmod ugo+x ninjareport