Add more Makefile templates
[matthijs/upstream/backupninja.git] / src / Makefile.am
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644 (file)
index 0000000..d0c77fc
--- /dev/null
@@ -0,0 +1,27 @@
+# tyhle vygenerujeme ...
+sbin_SCRIPTS  = backupninja ninjahelper
+
+# a proto je taky musíme smazat ...
+CLEANFILES = $(sbin_SCRIPTS)
+
+EXTRA_DIST = backupninja.in ninjahelper.in
+
+edit = sed \
+    -e "s,@CFGDIR\@,$(CFGDIR),g" \
+    -e "s,@BASH\@,$(BASH),g" \
+    -e 's,@datadir\@,$(pkgdatadir),g' \
+    -e 's,@localstatedir\@,$(localstatedir),g' \
+       -e 's,@prefix\@,$(prefix),g'
+
+#install-exec-hook:
+
+backupninja: $(srcdir)/backupninja.in
+       rm -f backupninja
+       $(edit) $(srcdir)/backupninja.in > backupninja
+       chmod ugo+x backupninja
+
+ninjahelper: $(srcdir)/ninjahelper.in
+       rm -f ninjahelper
+       $(edit) $(srcdir)/ninjahelper.in > ninjahelper
+       chmod ugo+x ninjahelper
+